Devolvendo a vida a um MSX Expert 2+ (KTPM2)

Por Mauro Xavier

Este post não é sobre como transformar seu MSX Expert. Também não é sobre como adicionar memória ou fazer outras proezas para melhorar sua saudosa máquina.

Hoje lhes apresento o sofrimento que passei durante 3 dias inteiros para restaurar o funcionamento completo de um MSX Expert 1.0 que já tinha um kit 2+ presente.

Prepare-se para fortes emoções…

O frankenstein quer viver!

Vi um anúncio que perdurou por mais de dois meses no Mercado Livre sobre um MSX Expert transformado para 2+. Deu para notar que o vendedor não entendia nada e as fotos somente mostravam “parte da obra”, mas já dava para perceber que o micro estava bem mal conservado.

Enfim acabei trocando o “frankstein” por um Xbox 1 (primeiro modelo). Não foi lá uma troca muito vantajosa para mim, mas já que o console estava praticamente encostado em casa resolvi pegar este MSX e “pagar pra ver” qual seria o resultado. Eu nem imaginava as dores de cabeça que estavam pela frente.

Esta era a foto real dele no Mercado Livre (clique para ampliar):

Ao chegar o micro a primeira coisa que fiz foi remover e guardar a pobre e judiada carcaça, estava sem condições, parece pior do que a foto acima. Fiz um “transplante” de toda a aparência externa de meu Expert Plus, que está quase intacto.

Ao ligar já tive o primeiro susto, era mesmo um MSX 2+ mas não tinha os supostos 256Kb de Mapper do anúncio do ML… Ok, já imaginava que o vendedor não sabia o que estava vendendo, mas espere aí, ainda por cima está preto e branco!? Mandei um e-mail notificando a ausência do TA-1 para converter o RGB em vídeo composto, mas foi em vão, o vendedor sequer sabia o que era isso.

Percebi também que o micro não ligava às vezes e estava esquentado muito na parte direita do gabinete, demonstrando que a fonte estava pedindo socorro. Até desejei fazer algo naquele momento mas já tinha ficado horas jogando nele, então deixei para o dia seguinte.

Por favor, me coloque uma fonte ATX!

Logo de manhã ao ligá-lo não teve acordo, nada de funcionar, morreu de vez.

Não pensei mais, simplesmente abri o gabinete, desmontei tudo e peguei uma fonte ATX nova de 200 Watts, ao qual tratei de começar a “operação”, seguindo o tutorial do site MSX Pró:

Não havia um lugar amigável para colocar a placa da fonte, então a instalei um pouco acima da placa analógica do Expert e isolei ambas, apesar de que naquele ponto nenhum componente ou trilha estavam se tocando.

Peguei uma fonte de potência menor na esperança de que os dissipadores também fossem menores, e BINGO! O tamanho era o ideal e não precisei fazer nenhum tipo de corte nos dissipadores:

Depois de finalizar os ajustes, cortei uma parte do cooler para que ele ficasse quase em cima da placa analógica, em uma região interessante para ventilar todo o gabinete e principalmente para aproveitar e parafusar a ventoinha em um furo já existente.

Tive que mudar a posição também do speaker, já que a placa ATX está agora exatamente na posição dele. Encontrei um lugar que aproveita a ventilação do gabinete para não abafar o som:

Com todas as modificações finalizadas e voltagens verificadas, estava na hora de ligar a criança e voltar a se divertir…

DJ, solta o som!

Liguei a saída de som nas minhas caixas 2.1 e de repente… NADA DE SOM FM!

Mas como assim? Antes o som estava saindo, será que fiz algo errado na ligação ATX? Testei o som do PSG e estava tudo normal, os jogos também estavam rodando bem, revi o tutorial e fiz todas as modificações necessárias para a instalação da fonte, então chegou a hora de abrir tudo novamente, para a minha profunda tristeza.

Para piorar mais um pouco, o micro em alguns momentos ainda teimava em não ligar, mas me servia de consolo que o problema de aquecimento estava totalmente resolvido com a nova fonte.

O kit de transformação para MSX 2+ deste Expert é um KTPM2 desenvolvido pelo Ademir Carchano em 1991:

Observando o kit mais de perto percebi que estava na hora de também dar uma geral nele. Pelo jeito o último dono deve ter armazenado o micro em algum lugar impróprio e úmido, pois boa parte das soldas pareciam oxidadas. Limpei tudo com álcool isopropílico e resolvi refazer TODAS as soldas:

Com esta pequena manutenção no kit KTPM2 o micro passou a ligar sempre, então provavelmente este problema estava relacionado a solda fria ou algo do gênero.

Com relação ao som, aproveitei e troquei alguns capacitores na placa FM e constatei que uma trilha do capacitor grande que fica ao lado da placa estava partida, refiz também todas as soldas, limpei tudo e executei outras pequenas correções, mas não foi suficiente para resolver o problema:

Depois peguei o datasheet do chip YM2413 para verificar os terminais, então fiz uma solda direta nos pontos MO e RO (saída de melodia e ritmo), somente para verificar se o processador responsável pelo MSX-Music estava funcionando ainda, e para meu alívio, estava tudo bem.

YM2413 é um processador de som FM desenvolvido pela Yamaha, sendo uma versão de baixo custo com alguns recursos reduzidos, exigindo a composição de filtros analógicos e amplificação imediata em sua saída para que o som possa ser reproduzido com um volume adequado. Em vista desta característica seria inviável e arriscado manter uma ligação direta no chip pois além do som ter ficado muito baixo, a sua frequência estava diferente da original devido a ausência dos filtros analógicos.

Fiz várias tentativas de ligação até chegar no responsável pela ausência do som FM: era o pequeno chip amplificador CA1458. Apesar de eu não ter encontrado um soquete de 8 pinos, improvisei um cortando soquetes maiores, mas milagrosamente consegui este chip em minha cidade:

Agora sim, bastou montar tudo novamente e o MSX estava “cantando” novamente.

Observação: Eu poderia ter usado também os chips NE5532 ou TL072, que são equivalentes diretos ao CA1458, de acordo com alguns membros do fórum Clube do Hardware. Na verdade mais adiante tentarei usar o NE5532, pois li em vários lugares que ele oferece um som melhor.

Mas e a memória de 256Kb ?

Fiquei curioso pois no kit KTPM2 está escrito “KIT 2+ / 2.0 / FM / MAPPER-256K“, e notei também que estão faltando alguns componentes:

Procurei pela internet até onde foi possível e sequer achei um diagrama ou maiores detalhes sobre este kit, então mandei um e-mail diretamente para o “pai da criança”, isto é, para o Ademir Carchano, que me respondeu educadamente o que segue abaixo:

Oi Mauro, dei uma olhada nas fotos e esse é uns dos primeiros Kits
KTPM2, o que achei interessante é ele ter FM e não ter Mapper, são
os CIs que estão faltando.

Os U17, U18 e U19 são TTLs comuns, somente o U16 que é uma GAL e
deve ser gravada, o problema é que esse KIT foi fabricado no
inicio da década de 1990, ou seja, são poucas as chances de eu ter
o arquivo que era gravado nela.

Mas vou procurar nos CDs de backup e ver se existe mais informação.

O restante seria colocar as 8-41256 e ligar alguns sinais no
conector CN4.

[] Carchano

Pois é, se tratando da memória mapeada de 256Kb deste kit só me resta esperar, pois sem documentação ou sem saber o que tem na programação do chip GAL será impossível aproveitar este recurso da placa.

Se de alguma forma for possível resolver este caso, criarei outro post exclusivamente para cobrir esta implementação extra.

Ao vivo, mas e as cores?

Pois é, não teve jeito, acabei sendo obrigado a comprar um TA-1 “no estado” pelo ML.

Para quem não sabe, o TA-1 é uma caixa externa responsável pela conversão dos sinais RGB da placa do MSX Expert 1.0 para vídeo composto e RF. Na revisões Expert 1.1 em diante estas conversões são realizadas por placas internas.

Segundo o relato de vários entusiastas, o TA-1 oferece uma imagem melhor em relação aos outros modelos de Expert, então eu estava curioso para ver se isso era realmente verdade, já que a última vez que vi um Expert 1.0 funcionando eu devia ter uns 7 anos de idade.

Ao chegar o aparelho tratei de ligar logo no Expert e então veio meu desespero mais uma vez… NADA DE IMAGEM.

Como eu estava com a paciência curta devido as manutenções anteriores, tratei logo de procurar os dois CIs da placa do TA-1, ao qual achei em minha cidade somente o MC1377. Depois descobri que era este mesmo o que precisava, pois ele é o responsável pela conversão dos sinais RGB para vídeo composto.

Nova tentativa, tentei ligar e nada. Abri o MSX novamente para mexer na placa analógica do Expert, e ao apertar um pouco a placa vi que a imagem tentou aparecer na tela, então ao mexer no conector RGB traseiro a imagem aparecia distorcida mas estava lá… Troquei o MC1377 novamente e vi que eram na verdade dois problemas, o chip realmente estava queimado e ainda para “melhorar as coisas” a saída RGB de minha placa analógica estava com mau contato.

E lá vou eu desmontar completamente todo o micro (pela enésima vez). Constatei TRÊS quebras de trilhas na parte do conector RGB, que só foi possível descobrir usando um multímetro,  a olho nu mesmo de perto não se vê falha alguma em duas delas:

Uma das trilhas foi resolvida com solda, mas nas outras duas tive que puxar fios mesmo:

E pacientemente monto novamente o micro e vou testar… PRETO E BRANCO!

Olhando o TA-1 percebo alguns componentes ajustáveis na placa, mexendo neles com MUITO CARINHO percebi que as cores começaram a querer aparecer timidamente. Sinceramente, FOI UM INFERNO ABSOLUTO ajustar plenamente as cores. Veja a imagem da placa do TA-1 abaixo:

No componente dentro do círculo a esquerda é ajustado a faixa do canal da cor, isto é, se regular errado todas as cores poderão ficar trocadas ou você terá diversas faixas na tela onde deveria existir uma única cor. Depois que ajustar o componente da esquerda e tiver algo piscando na tela ou algum tipo de cor, mesmo que incorreta, você deve ajustar com muita paciência o componente da direita, até que a cor fique estabilizada na tela. Se a cor continuar incorreta, volta-se ao componente da esquerda e assim por diante. Um verdadeiro teste a sanidade!

Lembre-se, você deve girar os componentes BEM LENTAMENTE, e se a cor correta aparecer tenha o reflexo de interromper IMEDIATAMENTE. Um pequeno toque extra e lá foi-se a regulagem novamente, nem voltando atrás a regulagem retorna ao estado anterior (WTF!?).

Para a regulagem usei os seguintes comandos em basic para testar as três cores primárias do processador de vídeo:

  • COLOR 15,4,4 – Azul escuro
  • COLOR 15,6,6 – Vermelho escuro. Em alguns televisores pode ter um tom levemente marrom
  • COLOR 15,12,12 – Verde escuro

Qualquer cor que apareça na tela de acordo com os comandos acima, pare imediatamente e teste os outros comandos. Se as três cores aparecerem corretamente, pode fechar o TA-1 e é só alegria.

“And the Oscar goes to…”

Agora é só curtir os jogos que meu MSX 2+ pode rodar por enquanto. Obviamente a felicidade ficará completa com ao menos 256Kb de mapper e uma IDE, quem sabe ainda não consigo uma IDE-Mapper de 512Kb com o amigo Ricardo Oazem?

E não é que o pessoal tem razão? Também achei excelente a qualidade da imagem através do TA-1, ficou muito melhor em relação a meu MSX Expert Plus:

Tudo bem que a imagem acima não é capaz de reproduzir toda a qualidade real ao vivo…

Mas enfim, o resultado de toda esta saga pode se resumir nesta foto:

Agora me deem licença que depois desta canseira toda, vou resgatar uns 20 anos de lombriga em poder curtir alguns jogos com um chip de FM real, SEM EMULAÇÃO ;)

Links para mais fotos e imagens em alta resolução

– Kit KTPM2 MSX 2+
– MSX Expert 1.0 / 2+ – Mod fonte ATX
– MSX 2+ Expert – Manutenção da placa lógica e ajuste de cores no TA-1

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s